極楽とんぼのロボット製作記

情報工学系大学院生がロボットとその周辺技術や身の回りの出来事について紹介するブログ

【ROS】The manifest (with format version 2) must not contain the following tags: run_depend

スポンサーリンク

ROSで自分で作ったメッセージをコンパイルしようとした際に出たエラーです。
エラー全文
Error(s) in /home/username/catkin_ws/src/segment_point_cloud/package.xml:

  • The manifest (with format version 2) must not contain the following tags: run_depend

ROSのチュートリアルにはpackage.xmlにrun_dependを追記するように書いてありますが、バージョンが新しくなってからはexec_dependを使用するようになっています。
package.xmlの中の
hoge

hoge
に変更すれば問題なく動きます。

参考にしたROSチュートリアル
ja/ROS/Tutorials/CreatingMsgAndSrv - ROS Wiki